Requirements for Joomla 3.x

 

Requirements for Joomla 3.x


Below is the requirement for Joomla 3.x:

Software

Recommended

Minimum

More information

PHP (Magic Quotes GPC off)

5.4 +

5.3.1 +

http://www.php.net

Supported Databases:




MySQL (InnoDB support required)

5.1 +

5.1 +

http://www.mysql.com

MSSQL

10.50.1600.1+

10.50.1600.1+

http://www.microsoft.com/sql

PostgreSQL

8.3.18 +

8.3.18 +

http://www.postgresql.org/

Supported Web Servers:




Apache

(with mod_mysql, mod_xml,

and mod_zlib)

2.x +

2.x +

http://www.apache.org

Nginx

1.1

1.0

http://wiki.nginx.org/

Microsoft IIS

7

7

http://www.iis.net


* Note: Please note that since Joomla 1.6, it is unable to install under Microsoft IIS7.

Add Feedback